Audi Q2 Forum banner
1 - 15 of 15 Posts

·
Registered
Joined
·
20 Posts
Discussion Starter · #1 ·
Hi,
I notice that my Q2 often does not remember the Drive Select mode I have selected and is set to some other mode when I start the car. I have to go back in and reselect my custom mode frequently.

Is this normal behaviour or a fault?

thanks
 

·
Registered
Joined
·
63 Posts
I have the DSG Box, always drive in Comfort and it is always in that mode when I start up unless I change it, I do not think it is normal for the mode the change otherwise.
 

·
Registered
Joined
·
20 Posts
Discussion Starter · #3 ·
I've been doing some research into this issue and it appears there is something to it.

The whole drive select mode doesn't reset but apparently the throttle response option will always reset to 'auto' regardless of the mode displayed when the car is restarted to allow for the engine to warm up.
 

·
Registered
Joined
·
68 Posts
silus said:
The whole drive select mode doesn't reset but apparently the throttle response option will always reset to 'auto' regardless of the mode displayed when the car is restarted to allow for the engine to warm up.
Hmm not sure on that as my car has been in Eco mode for the past month and the 'E' always shows next to the gear the car is in on the dash display.
 

·
Registered
Joined
·
11 Posts
I have an issue similar to this. Let me explain and please some tell me if I am paranoid. I select the efficiency mode in Audi drive select. The gears appear as E1 - E7. After i switch off and on the car it displays on the Virtual cockpit EFFICIENCY with green letters but the gears now appear as D1 - D7 and i also notice that it does not use the coasting mode anymore. So i have to press again the drive select (efficiency is selected already). Select another mode and then back the efficiency mode. Anyone else noticed this?
 

·
Registered
Joined
·
1 Posts
I have exactly the same issue but do not have the virtual cockpit. Every time I switch the car off and on again the E gear has changed back to D and doesn't coast. I have to manually select it again every time. I also noticed that on the odd occasion it has selected a different drive mode. Has anyone taken this up with Audi. Is it a fault?
 

·
Registered
Joined
·
20 Posts
Discussion Starter · #7 ·
Just a quick update as I've been having a back and forth with audi to get an answer to this which got escalated through several levels of Audi UK and I now finally have an official answer.

- yes the car does reset throttle response to ECO mode every time

- they acknowledge this happens despite what the MMI drive select screen says, so if you have it set to custom mode with dynamic throttle for example
It will still say it is in that mode but only the steering setting is how you left it. Throttle will be back in eco. Nor will you get the 'E' next to the gear when it has auto-reverted to eco. It is completely hidden.

- They acknowledge this little 'feature' is nowhere to be found in the manual, website, or anywhere you might look to find out

Their official response is that it is deliberate that you must deselect drive select mode every time if you want anything other than eco throttle response.

To be honest I am flabbergasted that they will sell an engine with a certain amount of power and yet it will not give you that power unless you select it every. Single. Time. Not only that but they don't tell you about this anywhere, you have to find it out by pure luck playing about with the settings.

They left it saying 'Audi Germany may or may not decide to do something about it' and this would only likely be making it more clear on the MMI that the setting has reverted rather than allowing it to actually remember the setting you specify.

I suspect that defaulting to eco mode is how they get the co2 levels down to make the car more attractive. The fact they hide the car does this makes me think twice before getting another Audi again, what else is going on behind the scenes I just haven't noticed yet :/

You can test this on your own vehicle. Set the car to dynamic mode, or a custom setting with dynamic throttle. Next time you start the car the throttle will be in eco, but press drive select and it will show the last mode you selected. Reselect that same mode and feel the boost.
 

·
Registered
Joined
·
1 Posts
Just registered to say that is something I've noticed on my Audi A3 1.6Tdi (2017) Sport Stronic

After reading this I understand the lack of consistency of the driver Select. I have a theory about this "reset" for the dynamic throttle to D after an ignition cycle, despite the of the cockpit showing efficiency mode and the prefix for the gear number letter should be E instead of D as shown.

As stated by "silus" this could and should be some kind of safety feature, but I don't agree that is something related with CO2 levels, but with the particle filter (at least on the diesel, don't know if you all have Diesel engines), very low revolutions on a cold engine generates higher level of particles on the exhaust gas circuit, forcing the engine to work harder, (more revs and no coasting) leads to a steeper increase on the temperature of the engine (oils and gases), activating the particle burning process in a short therm.

Of course this could be managed by the car computer. He knows that the car is cold and could work on specific regime until the car reaches the optimal temperature, and then, automatically go to the Drive Select chosen by the driver.

Sorry for my English, I hope you understand me
 

·
Registered
Joined
·
5 Posts
This is a personal bugbear of mine.

My Q2 has recently been in Blackburn Audi for warranty work and I had an A5 as a courtesy. If I set the latter to effi :evil: ciency mode it stays there. My wife's 67 plate A1 also stays there. I really cannot understand why my Q2 cockpit reads efficiency despite resetting EVERY time to D!!!! It really is infuriating. I mentioned it to Glasgow Audi where I bought it and Blackburn and they both gave an "emmissions" excuse, but I'm just not convinced. :cry:
 

·
Registered
Joined
·
48 Posts
if i change drive select mode the car remembers that postion , surely your selection on the stronic must be the same
if it does not , that is a backward step or a software error
i would be frustrated with that situation
 

·
Registered
Joined
·
5 Posts
I have to reset the drive select button every time I restart the engine. I had a 16 plate A3, same spec as the Q2 and it remembered the E setting. Audi seem to be aware of the issue with the Q2 but seem reluctant to do anything about it
 

·
Registered
Joined
·
6 Posts
silus said:
It will still say it is in that mode but only the steering setting is how you left it. Throttle will be back in eco. Nor will you get the 'E' next to the gear when it has auto-reverted to eco. It is completely hidden.
Have a glance at the A/C panel. ECO will be illuminated close to the LH knob, if the DS is set to ECO, but the E does not show beside the gear indicator.
 
1 - 15 of 15 Posts
Top